Welcome to My Voice for Globalstar and SPOT

We are dedicated to creating products that fit your life, keep you safe and bring you peace of mind when you are enjoying the world outside of cellular coverage. By working with UserVoice, we have created My Voice to let your voice be heard, gather your ideas for improvement, new products development and improved customer experience. While we cannot guarantee that any specific ideas will be implemented, we will ensure that your ideas and comments play a role in future updates, process and products.

Using My Voice
1 – Share your ideas. First check to see if it’s already been suggested and if so, vote for your favorites!
2 – If you have a new suggestion, submit it below.
3 – Ideas are reviewed for clarity, language and impact.
4 – If an idea has been considered for additional review, we’ll update its status.

My Voice for Globalstar and SPOT is a public forum, so we discourage you from providing any personal information within your ideas including account information.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Firmware via fax machine

    No, I don't have a fax machine.
    No, I don't have a landline.
    No, I don't have WIndows or Mac.
    No, I don't have a Linux installation.
    Yes, I do have Android, IOS and Chrome OS.

    I am able to meet all my computing/access needs except updates to an old Garmin and SpotX.

    Surely you are more creative and relevant than Garmin.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Firmware  ·  Flag idea as inappropriate…  ·  Admin →
  2. Firmware Updater Compatible with iPad

    Can you not make the firmware updates compatible with iPad or iPhone? Very few people use iMac anymore

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Firmware  ·  Flag idea as inappropriate…  ·  Admin →
  3. SPOT Gen 3 updater can't be executed on a Mac Catalina 10.15.5

    Using Mac Catalina 10.15.5. When opening the Updater software, get error message saying Apple can't validate the software and will not continue.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Merged  ·  0 comments  ·  Firmware  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base